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Abbreviations 
 
CAN Controller Area Network Serial communication protocol 
I/O-Box Input/Output box Optional box to connect sensors and to 

switch loads. 
SCC STEYR CONTROL CENTER  
SCCWinConfig STEYR CONTROL CENTER 

configuration software 
this manual describes these software 

 

Introduction 
 
With the STEYR CONTROL CENTER Configuration software you can configure your STEYR 
CONTROL CENTERs. The configuration of the SCCs can be changed and stored in the 
STEYR CONTROL CENTER Pool on the hard drive or it's possible to configure directly a via 
Active Sync to the host computer connected SCC. 
For archive or duplicate purpose you can copy the whole configuration of a connected SCC 
into the STEYR CONTROL CENTER Pool. 
The configuration of stored or changed SCCs in the STEYR CONTROL CENTER Pool can be 
transferred to the connected SCC. 
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Installation 
 

Microsoft ActiveSync 
You need to install Microsoft ActiveSync to connect a STEYR CONTROL CENTER to the 
computer. This is necessary to access and change data from an SCC. 
If ActiveSync is already installed on the computer and a connection to an SCC is possible, 
then you don't have to install ActiveSync again. 
 
How to check, if a connection via ActiveSync between an SCC and the computer is 
possible? 
In the ActiveSync connection settings enable the USB connections, power up the SCC and 
connect it with the USB cable to a free USB port of the computer. The connection wil be 
established automatically. Confirm the question; if you want to set up a partnership with 
the device, with no, a guest connection is enough to configure the SCC. 
 

STEYR CONTROL CENTER Configuration Software 
For installation simply run the setup program "InstallSCCWinConfig.msi" from the setup 
CD or download the newest version from the internet. 
ATTENTION: uninstall any previous installed version before installing a new one!  
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Application interface 

Main window 

 
 

Route window Data window 

Menu 

Toobar 

Status bar 

Picture 1: application window 
 
Menu: application menu 
 
Toolbar: with the save button changes are stored in the STEYR CONTROL CENTER Pool on 

the hard drive or the connected SCC is updated. 
 
Route window: all stored SCCs and the connected SCC are listed in this area. 
 
Data window: depending on which item is selected in the route window, all configurable 

values are shown in this area. 
 
Status bar: in this line is a short description of selected menu or context menu entries 
shown. 
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Application menu 
 
Menu "File": 

• "Save Ctrl+S": saves all changes onto the hard drive, if data 
in the SCC pool are changed or transfers changes to the 
connected SCC, if changes were made on the connected SCC 

• "Exit": quits the application, if changes were made the 
application will ask to save them. 

 
 
 
 
Menu "Option": 

• "Set path of SCC pool …": sets the path on the hard 
drive where all SCC and grouping folders should be 
saved. 

 
 
 
 
Menu "View": 

• "Toolbar": shows or hides the toolbar 
• "Status Bar": shows or hides the status bar 

 
 
 
 
Menu "Help": 

• "About SCCWinConfig …": shows version information 
 
 
 
 
Toolbar: 
 

•         same as menu "File" -> "Save" 
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Route window 
 

 
Symbols: 
 

     Main element for the STEYR CONTROL  
        CENTER Pool 
 

     Grouping folder 
 

      STEYR CONTROL CENTER 
 

      I/O-Box 
 

      Relay output 
 

      Sensor input 
 

      Via ActiveSync connected SCC 
 
 
 

Picture 2: route window 
 
Under the main element "STEYR Control Centers" it's possible to create grouping folders 
and STEYR CONTROL CENTERs. Grouping folders are useful to get a structure in the 
configured SCCs. Use these folders for example for customers, a boat configuration, 
places … 
The second main element "Connected SCC" is only available if an SCC is connected via 
ActiveSync to the computer, this has the same functionality as an SCC which is stored in 
the pool. 
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How to work with the application? 

STEYR CONTROL CENTER pool: 
 
The SCC pool is a directory on the hard drive or a mounted network share. The pool 
consists of grouping folders and configured STEYR CONTROL CENTERs. Grouping folders 
can contain other grouping folders, STEYR CONTROL CENTERs or both. 
By default the directory for the SCC pool is "SCCPool" under the installation path of the 
SCCWinConfig software. You can change the SCC pool directory with the menu item 
"Options" -> "Set path of SCC pool …". 
 

What is configurable of a STEYR CONTROL CENTER? 
• Time zone 
• Gear ratio 
• Propeller pitch 
• Volume and alarm level of manual tank 
• Unit values 
• CAN behaviour 
• Default I/O-Box 
• I/O-Boxes 

 

Handling with the user interface 
 
Creating, deleting, renaming, copying or transferring objects (grouping folders, SCCs, I/O-
Boxes, outputs or sensors) is done over the context menu when clicking with the right 
mouse button on an element in the route window. 
 
When adding an object, the object is always added as a sub element from the selected 
element in the route window. 
 
To change data of an object (SCCs, I/O-Boxes, outputs or sensors) select the 
corresponding element in the route window. After this, all configurable data are shown in 
the data window. 
Important: when entering fraction of numbers always use the decimal point (e.g. "15.7") 
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Saving changed data in the SCC pool 
 
After changes have been made the data must be saved (e.g. with menu "File" -> "Save") 
before quitting the application to store the changes permanently in the pool. 
Some changes are stored immediately in the pool without the need to save them explicitly, 
these are: 

• renaming a grouping folder or SCC 
• deleting a grouping folder or SCC 
• creating a new grouping folder or SCC 
• copying an SCC 

 

Saving changed data of the "Connected SCC" 
 
Each change is done temporary on the hard drive, so you have to save your work (e.g. 
with menu "File" -> "Save") before quitting the application or disconnecting the SCC from 
ActiveSync. After saving, you must restart the STEYR CONTROL CENTER to take effect of 
the new settings. If you do not save the changed data and disconnect the SCC from 
ActiveSync or quit the application, all changes will be lost. 
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Configure STEYR CONTROL CENTERs 

Adding a new grouping folder 
 
Right click the "STEYR CONTROL CENTERs" element or another grouping folder in the 
route window, in the following context menu select "New Folder" and input a name for it. 
 

Adding a new STEYR CONTROL CENTER 
 
Right click the "STEYR CONTROL CENTERs" element or a grouping folder in the route 
window, in the following context menu select "New STEYR CONTROL CENTER" and input a 
name for it. After confirming the "Enter name" input box with "OK" the new SCC will be 
added with default configuration settings. 
 

 
Picture 3: create a new SCC 
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Configure a STEYR CONTROL CENTER 
 

 
Picture 4: configurable data of an SCC 

 
When selecting an SCC in the route window you can configure data as shown in the above 
picture. 
 

Configurable common SCC data 
 

• Time zone: when a GPS sensor is connected to the STEYR CONTROL CENTER then 
the time zone must be configured, because the received GPS time is UTC time. 
Allowed values: all values from the drop down list 

• Gear ratio: to calculate the theoretical speed and the corresponding slip value, this 
value is required (i.e. 2.1) 
Allowed values: any positive decimal number 

• Propeller pitch: this value is needed for the same reason as the gear ratio 
Allowed values: any positive decimal number (i.e. 20”) 

• Tank volume: tank volume of the manual tank 
Allowed values: any positive integer 

• Alarm level: level, when the SCC should show a warning if the actual contents of 
the manual tank falls below this threshold. 
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Allowed values: any positive integer and "-1". If "-1" then no alarm level is 
configured. 

• Units: unit which is shown for speed, temperature, pressure or volume values in 
the SCC software 
Allowed values: any selection  

• CAN behaviour: it is possible to connect more than one SCC on the same CAN line 
at different places, e.g. to view engine or sensor data or to switch an I/O-Box 
relay output from different locations on a boat. At start up the "Master SCC" 
initializes the I/O-Boxes and "Slave SCCs" with important values for the CAN 
communication and this is only allowed from just one "Master SCC". So, for a 
functional communication between the engine, SCCs and I/O-Boxes it's 
necessary to have just one "Master SCC" and any number (zero is also possible) 
of "Slave SCCs". 
Allowed values: see description above 

 

Elements below an SCC element in the route window 
 

 
Picture 5: elements below SCC element 

 
 

• "Default I/O-Box": 
Each SCC has a "Default I/O-Box" member, which can be configured like a 
normal I/O-Box except for the serial number. This configuration will be used if 
an SCC recognizes a new or unknown I/O-Box. SCC’s recognize the I/O-Boxes 
by there serial number. 
Recommended configuration: when using only one I/O-Box, configure the 
"Default I/O-Box" equal to the connected one. The advantage is, when you 
change the I/O-Box due to a defect, you don't have to set up the new one. 

 
• "I/O-Boxes": 

The "I/O-Boxes" folder can contain an unlimited number of configured I/O-
Boxes which the STEYR CONTROL CENTER knows. 
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Adding a new I/O-Box to a STEYR CONTROL CENTER 
 

 
Picture 6: Add a new I/O-Box 

 
Right click the "I/O-Boxes" folder of the STEYR CONTROL CENTER where you want add a 
new I/O-Box in the route window, in the following context menu select "Add new I/O-Box" 
and input a name for it. After confirming the "Enter name" input box with "OK" the new 
I/O-Box will be added with default configuration settings (from the "Default I/O-Box"). 
After this enter a correct serial number for the new I/O-Box because zero is not allowed. 
 

Configure a I/O-Box 
 

 
Picture 7: configurable data of an I/O-Box 

 
When selecting an I/O-Box in the route window you can configure data as shown in the 
above picture. 
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Configurable common I/O-Box data 
 

• Serial number: serial number of the I/O-Box for which this configuration is valid. 
This number is very important, because the STEYR CONTROL CENTER 
recognizes the connected I/O-Boxes through there serial numbers. According to 
the serial number the SCC knows which configuration it should take to calculate 
and show data from the I/O-Box. 
The configuration of an I/O-Box is always stored on the SCC and not in the 
I/O-Box itself. The only thing which is permanently programmed into the 
I/O-Box is its serial number. 
Allowed values: any positive integer except zero 

• Priority: when more than one I/O-Box is connected to the STEYR CONTROL 
CENTER, the priority defines the order of the recognized I/O-Boxes in the 
I/O-Box view of the SCC software. Null means the highest priority and 255 the 
lowest. The order is random if two ore more I/O-Boxes have the same priority. 
Allowed values: any slider position 

 

Elements below an I/O-Box element in the route window 
 

 
Picture 8: elements of an I/O-Box 
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• "Outputs": 

The "Outputs" folder contains the configured relay outputs of an I/O-Box. 
The order of the outputs in the route window is important, because it 
represents the pinning on the I/O-Box output connector. The first output in the 
route is the first relay place on the output connector (Pin 1 and Pin 12) of the 
I/O-Box, the second output is the second relay place, etc. (for a connector 
description of the I/O-Box see the SCC technical documentation) 
 

• "Sensors": 
The " Sensors" folder contains the configured sensor inputs of an I/O-Box. 
The order of the sensors in the route window is important, because it 
represents the pinning on the I/O-Box sensor connector. The first sensor in the 
route is the first sensor input place on the sensor connector (Pin 1 and Pin 8) of 
the I/O-Box, the second sensor is the second sensor input place, etc. (for a 
connector description of the I/O-Box see the SCC technical documentation) 

 

Adding a new output to an I/O-Box 
 

 
Picture 9: Add a new output 

 
Right click the "Outputs" folder of the I/O-Box where you want to add a new output in the 
route window, in the following context menu select "Add new output" and enter a name 
for it. After confirming the "Enter name" input box with "OK" the new output will be added 
with default configuration settings. 
Maximally four outputs are permitted. 
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Configure an output 
 

 
Picture 10: configurable data of an output 

 
When selecting an output in the route window you can configure data as shown in the 
above picture. 
 
 

Configurable output data 
 

• Auto off time: duration after which time an active output is switched off 
automatically. Attention: the unit of this value is 1/10 seconds (e.g. a value of 
"100" means ten seconds). 
Allowed values: any positive integer. Zero means no automatic switch off 

• Push button: when checked the button in the I/O-Box view of the SCC software is 
a push button. That means, that an output is only switched on when the button 
is pressed in the SCC software. 
When "Push button" is not checked the output is like a normal switch. 
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Changing the position of an output 
 
Right click the output element in the route window from which 
you want change the position, in the following context menu 
select "Move up" or "Move Down". Repeat this step until the 
output is placed correctly. 
 
The top position is the top left button in the STEYR CONTROL CENTER, 
one below top is for top right button, 3 rd from top is bottom left and bottom position is 
the bottom right button on the display. 

Renaming an output 
 
Right click the output element in the route window of which you want change the name, 
in the following context menu select "Rename output". 
The name of an output is equal to the label of the corresponding button in the SCC 
software. 
 

Adding a new sensor to an I/O-Box 
 

 
Picture 11: Add a new sensor 

 
Right click the " Sensors" folder of the I/O-Box where you want add a new sensor in the 
route window, in the following context menu select "Add new sensor" and input a name 
for it. After confirming the "Enter name" input box with "OK" the new sensor will be added 
with default configuration settings. 
Maximally four sensors are permitted. 
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Configure a sensor 
 

 
Picture 12: configurable data of a sensor 

 
When selecting a sensor in the route window you can configure data as shown in the 
above picture. 

Configurable sensor data 
 

• Sensor type: see sensor type description below 
• Sensor: in this drop down list you can find all predefined sensors of the selected 

sensor type. When selecting any predefined sensor all data except the red 
region parts are filled out. 
When selecting the "self defined sensor" entry from the drop down list, it's 
possible to configure all values from the sensor yourself. 

• Filter: number of measured sensor values to calculate an average value. This is 
useful for a sensor which has a huge fluctuation (e.g. tank level sensors). The 
average value is shown in the corresponding instrument in the I/O-Box view of 
the SCC software. The I/O-Box measures and sends the sensor values 
approximately every second, so a filter value from max. five is recommended. 
Allowed values: any slider position. Zero and one means no filter is used, the 
sensor values are shown directly in SCC software. 
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• Sensor max. value: resistance of the sensor when it reaches the highest possible 
scale value. Attention: the unit of this value is 1/10 ohm (e.g. a value of "1000" 
means 100 ohms). 
Allowed values: positive integer 0 - 65535 

• Sensor min. value: resistance of the sensor when it reaches the lowest possible 
scale value. Attention: the unit of this value is 1/10 ohm (e.g. a value of "1000" 
means 100 ohms). 
Allowed values: any positive integer 0 - 65535 

• Scale max. value: value which is shown in the instrument at the end of the scale. 
Allowed values: integer -999 - +999 

• Scale min. value: value which is shown in the instrument at the start of the scale. 
Allowed values: integer -999 - +999 

• Scale unit: unit of the values "Scale max. value" and "Scale min. value". Attention: 
this is not the unit which is shown for the instrument in the SCC software. The 
instrument unit is configured in the common SCC settings. The scale unit is 
needed for a conversion into the different shown units. 

• Enable upper red region: enables the possibility to configure an upper red region 
and a high alarm warning. 

• Upper red region: scale value at which the upper red region should start. 
Allowed values: interger, value must be lower than "Scale max. value" and 
greater than "Scale min. value". 

• Enable high alarm: if enabled, a warning popup appears on the SCC when the 
sensor value is greater than the "Upper red region" value. 

• Engine must run: if enabled, the high alarm warning appears only when the 
sensor value is greater than the "Upper red region" value and the engine is 
running. 

• Enable lower red region: enables the possibility to configure a lower red region 
and a low alarm warning. 

• Lower red region: scale value at which the lower red region should end. 
Allowed values: interger, value must be lower than "Scale max. value" and 
greater than "Scale min. value". 

• Enable low alarm: if enabled, a warning popup appears on the SCC when the 
sensor value is lower than the "Lower red region" value. 

• Calibration values: see "Calibration values" below 

Sensor type description 
 
Possbile sensor types are: 
• Empty sensor place:  

When "Empty sensor place" is selected, then the corresponding sensor place in 
the I/O-Box view of the SCC software is empty. This is needed when the sensor 
place on the I/O-Box connector is not used. 
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• Fuel sensor: 
Fuel level sensor for tanks. Sensors of this type can be selected as used tank 
sensor in the tank view of the SCC software 

• Temperature senor: 
Temperature sensors 

• Pressure sensors: 
Pressure sensors 

• Digital sensors: 
Digital sensors are sensors which have only two states, on and off like a switch. 
The only thing you can configure with a digital sensors is: 
* a high alarm warning when the switch is closed (null ohm) 
or 
* a low alarm warning when the switch is opened (∞ ohm) 
 
Predefined digital sensor "Screen off mode": 
If this sensor is selected and the corresponding sensor switch is closed, then 
the display backlight of the SCC is switched off. When the sensor switch is 
opened the backlight is turned on again. 

• Common sensor: 
Sensors with no special type 

Calibration values 
 
Calibration values are necessary to define non linear sensors. 
When defining sensors without any calibration values, then the scale value is calculated 
with the linear interpolation method between the sensor min. and max. value. 
Calibration values are always two values: the resistance value of the sensor and the 
corresponding scale value. This pair of values defines a point in the sensor curve. A sensor 
can have an unlimited number of calibration values. 
Attention: when defining a calibration value pair, the resistance value must be given in 
1/10 ohm. 
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Picture 13: calibration values input dialog 

 
The order of the values listed in the calibration values dialog is very important: the 
calibration value pair with the lowest scale value has to be at the top, at the bottom of the 
list the value pair with the highest scale value. The list is ordered from the lowest scale 
value to the highest scale value. The lowest or highest scale value of the calibration values 
may not be the same as the scale min. or max. It's also possible to start and end with the 
calibration values somewhere in the middle of the sensors scale bandwidth. 
In the picture above you see a sensor with the behaviour: when the resistance of the 
sensors goes up the scale value goes up too. There are also sensors, like temperature 
sensors (NTC's), with the opposite behaviour: when the resistance goes up the scale value 
falls (see the picture bellow). 
 

 
Picture 14: raising resistance – falling scale value 

 
Attention: when defining calibration values, you must always define them in 
the right order. 
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Changing the position of a sensor 
 
Right click the sensor element in the route window of which 
you want change the position, in the following context menu 
select "Move up" or "Move Down". Repeat this step until the 
sensor is placed correctly. 
 
The top position is the top middle instrument in the STEYR CONTROL CENTER, 
one below top is for the bottom left instrument, 3 rd from top is bottom middle and bottom 
position is the bottom right instrument on the display. 
 

Renaming a sensor 
 
Right click the sensor element in the route window of which you want change the name, 
in the following context menu select "Rename sensor". 
The name of a sensor is equal to the label of the corresponding instrument in the SCC 
software. 
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Working with the "Connected SCC" 
 
Change the connected SCC directly: 
When a STEYR CONTROL CENTER is connected to the host computer via ActiveSync you 
see the element  in the route window. You can configure the connected 
SCC like a normal SCC which is saved in the pool. When you are finished with the 
configuration don't forget to save (menu "File" -> "Save") your work. When disconnecting 
the SCC from the host computer without saving, you will lose all your configuration 
changes. 
After saving changes of the connected SCC, you have to perform a restart of the SCC to 
take effect the new configuration. 
 
Transfer the configuration of an SCC in the pool onto the connected SCC: 
After you have finished the configuration of SCCs in the SCC pool, you may want to 
transfer the settings from an SCC inside the pool onto the connected SCC. This is easily 
done by selecting with the right mouse button on the relevant SCC in the pool and 
selecting in the following context menu "Transfer STEYR CONTROL CENTER". The entry 
"Transfer STEYR CONTROL CENTER" is only available if an SCC is connected to the host 
computer via ActiveSync. 
 

         
Picture 15: Transfer to connected SCC and copy connected SCC 

 
Copying the connected SCC into the SCC pool: 
To store the connected SCC inside the SCC pool, right click the "Connected SCC" element 
in the route window and select "Copy connected STEYR CONTROL CENTER". Now right 
click a grouping folder or "STEYR CONTROL CENTERs" and select "Paste STEYR CONTROL 
CENTER", enter a name for the SCC and confirm the box with "OK". The configuration of 
the connected SCC is saved below the folder where you have selected "Paste STEYR 
CONTROL CENTER". 
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The "About SCCWinConfig" dialog 
 
To obtain version information of the application and the available predefined sensors, 
select menu "Help" -> "About SCCWinConfig…". 
 

 
Picture 16: "About SCCWinConfig" dialog 
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